Sorry... I can't deal with all the SPAM so until I can find a better solution for the forums, I'm locking them down. For now please use awesome services like stackoverflow.com for community support. Thanks.
This forum is a community forum meant for users of the plugin to collaborate and help solve issues with implementation, etc. Unfortunately, as the creator of the plugin, I do not have much time to attend to every request here as this is only a side project and I must work a full-time job to provide for my family. This is how I keep the Flash version free and the HTML5 version low cost.
Crossdomain uploading
  • I am using Uploadify v2.1.4

    For 'same domain upload' I am using the following code which works ok:
    $("#fileUpload").uploadify({
    'scriptAccess': 'always',
    'uploader': '/Scripts/uploadify/uploadify.swf',
    'script': 'upload',
    'multi': false,
    'auto': true,
    'scriptData' : { SessionId: .... etc },
    }


    For 'cross domain upload' I have added crossdomain.xml to both domainA and domainB, and replaced the uploader and script parameters with:

    'uploader': 'http://www.domainB.com/uploadify.swf',
    'script': 'http://www.domainB.com/upload.aspx',


    • The Uploadify button shows, and I can select a file. The progress bar shows up, but then nothing more happens.
    • I have tested the domainB/upload.aspx with a standard form post from domain A, this works.
    • I have debugged through Uploadify.js and it is calling startFileUpload on the flash component, then nothing more happens (I don't know how to debug into the flash).
    • I see from uploadify.fla that the flash component should not add pagePath to the script url since it starts with "http", so I guess the UrlRequest is ok.


    Do you have any suggestions what I could look at next?
  • I have the exact same issue. Did someone find a solution?

    thanks and regards
  • I believe I may also be experiencing an issue with this. I also see the progress bar display, and then nothing more happens with a script hosted on a remote server. I'm not getting any errors messages either.
  • Hello,

    I have the exact same problem too.
    Has anyone been able to solve it by now?
  • Hi,

    have the same problems!

    Nobody solves the problem ?????
  • Try using the local uploadify.swf file instead of the remote one
  • You might be able to make some magic happen by rolling in easyXDM. http://easyxdm.net/wp/

    I've used it and it is a very nice cross domain library, havent used it with uploadify though
  • Thanks zazinteractive. It's worked great